Задать вопрос
6 февраля, 09:53

Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case).

+2
Ответы (1)
  1. 6 февраля, 12:54
    0
    Var n, d:integer;

    begin

    write ('Введите месяц : ') ;

    readln (n) ;

    write ('Введите день : ') ;

    readln (d) ;

    n:=n mod 12;

    case n mod 12 of

    1: if d<=20 then writeln ('Козерок') else writeln ('Водолей') ;

    2: if d<=21 then writeln ('Водолей') else writeln ('рыба') ;

    3: if d<=21 then writeln ('рыба') else writeln ('овен') ;

    4: if d<=21 then writeln ('овен') else writeln ('телец') ;

    5: if d<=21 then writeln ('телец') else writeln ('близницы') ;

    6: if d<=22 then writeln ('близницы') else writeln ('рак') ;

    7: if d<=23 then writeln ('рак') else writeln ('лев') ;

    8: if d<=24 then writeln ('лев') else writeln ('дева') ;

    9: if d<=24 then writeln ('дева') else writeln ('весы') ;

    10: if d<=24 then writeln ('весы') else writeln ('скорпион') ;

    11: if d<=23 then writeln ('скорпион') else writeln ('стрелец') ;

    12: if d<=22 then writeln ('стрелец') else writeln ('козерок') ;

    end;

    end.

    //без if вряд ли удаться обойтись (+ я не учитывал високосный год и кратный 100 и 400)
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Pascal ABC. Написать программу которая определяет знак зодиака при вводе даты рождения (с использованием case). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы