Задать вопрос
24 марта, 22:00

Написать программу, которая запрашивает строку и выводит на экран 1-й, 2-й и 5-й символы.

Паскаль abc.

+3
Ответы (2)
  1. 24 марта, 22:40
    0
    Var s:string;

    begin

    writeln ('Введите строку:') ;

    readln (s) ;

    writeln ('s[1] = ', s[1],', s[2] = ', s[2],', s[5] = ', s[5]) ;

    end.

    Пример:

    Введите строку:

    Microsoft

    s[1] = M, s[2] = i, s[5] = o
  2. 25 марта, 00:50
    0
    Переводим строку в массив символов. По красоте можно создать отдельно массив.

    var s : String;

    begin

    Read (s) ;

    Writeln (s. ToCharArray () [0]) ; / / число - 1 т. к. начинается все с нуля

    Writeln (s. ToCharArray () [1]) ;

    Writeln (s. ToCharArray () [4]) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая запрашивает строку и выводит на экран 1-й, 2-й и 5-й символы. Паскаль abc. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы