Задать вопрос
9 сентября, 10:42

1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления суммы всех трехзначных чисел, кратных 17. (паскаль, тремя способами)

+2
Ответы (1)
  1. 9 сентября, 13:29
    0
    1)

    Program Pr1;

    uses crt;

    var mas:array[100 ... 999] of integer;

    i:integer;

    Begin

    clrscr;

    for i:=100 to 999 do mas[i]:=i; {1 sposob}

    for i:=100 to 999 do if mas[i] mod 9 = 0 then writeln (mas[i]) ;

    i:=100; {2 sposob}

    while i<=999 do begin

    if mas[i] mod 9=0 then writeln (mas[i]) ;

    i:=i+1;

    end;

    i:=100; {3 sposob}

    repeat

    if mas[i] mod 9=0 then writeln (mas[i]) ;

    i:=i+1

    until i=999

    end.

    2)

    Program Pr1;

    uses crt;

    var mas:array[100 ... 999] of integer;

    i, v:integer;

    Begin

    clrscr;

    v:=0;

    for i:=100 to 999 do mas[i]:=i; {1 sposob}

    for i:=100 to 999 do if mas[i] mod 17 = 0 then v:=v+mas[i];

    writeln (v) ;

    i:=100; {2 sposob}

    v:=0;

    while i<=999 do begin

    if mas[i] mod 17=0 then v:=v+mas[i];;

    i:=i+1;

    end;

    writeln (v) ;

    i:=100; {3 sposob}

    v:=0;

    repeat

    if mas[i] mod 17=0 then v:=v+mas[i];

    i:=i+1

    until i=999;

    writeln (v) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. составить программу вывода на экран всех трехзначных чисел, кратных 9. (паскаль, тремя способами) 2. Составить программу вычисления ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы