Задать вопрос
9 октября, 08:21

Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся на цифру 7

+4
Ответы (1)
  1. 9 октября, 09:33
    0
    Const

    K = 10;

    Var

    A:array[1 ... K] of integer;

    S, i, n:integer;

    Begin

    S:=0;

    n:=0;

    Write ('Исходный массив: ') ;

    For i: = 1 to K do

    Begin

    A[i]:=random (201) - 100;

    Write (A[i],' ') ;

    if A[i] mod 10 = 7 then

    Begin

    S:=S+A[i];

    n:=n+1

    End;

    End;

    WriteLn;

    if n = 0 then WriteLn ('В массиве нет элементов, оканчивающихся на семь')

    else WriteLn ('Среднее арифметическое элементов, оканчивающихся на семь: ', S/n) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Массив из 10 элементов заполняется целыми числами. Составьте программу, которая вычисляет среднее арифметическое элементов, заканчивающихся ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы