Задать вопрос
2 ноября, 00:50

Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа. Используйте пригласительную строку. Используйте процедуру очистки экрана (для ТП). Установите формат вывода данных: 6 позиций для всего числа, 2 позиции - для доробной части.

Дополнительно: напишите программу, которая меняет местами цифры в целом двузначном числе. Например:

Входные данные: 35

Результат: 53

+1
Ответы (1)
  1. 2 ноября, 03:33
    0
    1)

    uses crt;

    var chislo, summa, proiz:integer;

    begin

    clrscr;

    Readln (chislo) ;

    summa: = (chislo div 10) + (chislo mod 10) ;

    proiz: = (chislo div 10) * (chislo mod 10) ;

    Writeln (' сумма:', summa:6:2) ;

    Writeln (' произведения : ', proiz:6:2) ;

    end.

    2)

    var chislo:integer;

    begin

    Readln (chislo) ;

    chislo: = (chislo div 10) + (chislo mod 10) * 10;

    Writeln (chislo) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу подсчета суммы и произведения цифр для данного целого двузначного числа. Используйте пригласительную строку. Используйте ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы