Задать вопрос
13 мая, 14:16

Напишите программу на языке Паскаль!

С клавиатуры вводится три четырёх значных числа. Найти сумму нечётных цифр в наименьшем числе.

+1
Ответы (1)
  1. 13 мая, 16:49
    0
    Var

    a, b, c, sum: integer;

    function min (x, y: integer) : integer;

    begin

    if (x > y) then result : = y

    else result : = x;

    end;

    begin

    sum : = 0;

    read (a, b, c) ;

    a : = min (a, min (b, c)) ;

    while a > 0 do

    begin

    if (a mod 10 mod 2 0) then sum : = sum + a mod 10;

    a : = a div 10;

    end;

    write (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу на языке Паскаль! С клавиатуры вводится три четырёх значных числа. Найти сумму нечётных цифр в наименьшем числе. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы