Задать вопрос
18 декабря, 05:25

Каждый ежедневно болеющий гриппом человек может заразить окружающих. Составьте программу, определяющую, через сколько дней заболеют все ученики школы. Число учащихся школы ввести с клавиатуры.

+5
Ответы (1)
  1. Н
    18 декабря, 08:13
    0
    При условии что каждый больной заражает от 1 до 5 человек каждый день, и что больные упорно ходят в школу

    const

    min_posible = 1;

    max_posible = 5;

    var all_students, ill, new_ill, days, i: integer;

    Begin

    Randomize;

    Writeln ('Кол-во учеников школы = >') ;

    read (all_students) ;

    ill : = 1;

    repeat

    days : = days + 1;

    new_ill : = 0;

    for i : = 1 to ill do

    new_ill : = new_ill + Random (min_posible, max_posible) ;

    ill : = ill + new_ill;

    Writeln ('День ', days:3,': Заразилось ', new_ill:5,' Больных ', ill:5) ;

    until ill > = all_students;

    Writeln (days) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Каждый ежедневно болеющий гриппом человек может заразить окружающих. Составьте программу, определяющую, через сколько дней заболеют все ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Войти
Задать вопрос