Задать вопрос
30 июля, 19:15

Дано четырехзначное числою определить сумму первой и последней цифры и 2 и 3 помогите написать программу по паскалю

+5
Ответы (2)
  1. 30 июля, 19:50
    0
    Var

    A:integer;

    Begin

    WriteLn ('Введите четырёхзначное число') ;

    ReadLn (A) ;

    WriteLn ('Сумма цифр:') ;

    WriteLn ('Первой и последней = ', A div 1000 + A mod 10) ;

    WriteLn ('Второй и третьей = ', (A div 100) mod 10 + (A div 10) mod 10) ;

    End.
  2. 30 июля, 23:04
    0
    Uses crt;

    var s: String;

    i1, i2, err: Integer;

    r: Integer;

    begin

    readln (s) ;

    clrscr;

    val (s[1], i1, err) ;

    val (s[Length (s) ], i2, err) ;

    r : = i1 + i2;

    writeln (r) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четырехзначное числою определить сумму первой и последней цифры и 2 и 3 помогите написать программу по паскалю ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы