Задать вопрос
11 апреля, 10:59

Напишите программу, которая вычисляет факториал натурального числа N (1 ≤ N ≤ 10000), сохранив все значащие цифры. Факториалом называется произведение всех натуральных чисел от 1 до N : N! = 1·2·3 ... (N - 1) · N.

+3
Ответы (1)
  1. 11 апреля, 14:04
    0
    Program n1;

    var

    n, i: integer;

    p: real;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    if (n>=1) and (n<=10000) then

    begin

    p : = 1;

    for i : = 2 to n do

    p : = p * i;

    writeln (n, '! = ', p) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая вычисляет факториал натурального числа N (1 ≤ N ≤ 10000), сохранив все значащие цифры. Факториалом называется ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы