Задать вопрос
23 ноября, 16:11

Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - нечетный, а модуль второго меньше 5. Парой элементов считаются два рядом стоящие элемента.

+5
Ответы (1)
  1. 23 ноября, 16:38
    0
    Const

    N = 5;

    Var

    A:array[1 ... N] of integer;

    i, k:integer;

    Begin

    Write ('Исходный массив: ') ;

    For i: = 1 to N do

    Begin

    A[i]:=random (21) - 10;

    Write (A[i],' ') ;

    End;

    WriteLn;

    k:=0;

    For i: = 1 to N-1 do

    if ((A[i] mod 2 0) and (abs (A[i+1]) <5))

    or ((A[i+1] mod 2 0) and (abs (A[i]) <5)) then k:=k+1;

    WriteLn (k)

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Массив из 5 элементов заполняется целыми числами. Составьте программу, которая вычисляет количество пар элементов, у которых один элемент - ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы