Задать вопрос
30 августа, 19:09

1. С клавиатуры вводится X и N. Составь алгоритм вычисления X в степени N. Напиши программу на Паскале

+4
Ответы (2)
  1. 30 августа, 22:51
    0
    Var

    x, n, res : integer;

    begin

    res : = 1;

    readln (x) ;

    readln (n) ;

    for var i:=1 to n do res : = res * x;

    writeln (res) ;

    end.

    пишу с телефонв, не уверен, может быть в строке for ... надо n-1 а не просто n
  2. 30 августа, 23:06
    0
    var

    n, i, a: integer;

    p: BigInteger;

    begin

    p : = 1;

    Writeln ('Введите числа') ;

    Write ('a=') ;

    Readln (a) ;

    Write ('n=') ;

    Readln (n) ;

    for i : = 1 To n Do p : = p * a;

    writeln (p) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1. С клавиатуры вводится X и N. Составь алгоритм вычисления X в степени N. Напиши программу на Паскале ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы