Задать вопрос
14 ноября, 19:45

Помогите! Нужно написать программы на Pascal + блок-схемы.

С клавиатуры последовательно вводится n-целых чисел:

1) Сколько чисел отличаются от первого на величину а?

2) Для всех чисел, кроме 1 и последнего, определите, сколько из них больше своих соседей? (слева и справа)

3) Вывести числа, которые делятся на 3, но не делятся на 5.

+1
Ответы (1)
  1. 14 ноября, 22:45
    0
    Const

    n = 13;

    Var

    a, i, C, k:integer;

    M:array[1 ... N] of integer;

    Begin

    k:=0;

    Write ('a = ') ;

    ReadLn (a) ;

    WriteLn ('Введите целые числа') ;

    For i: = 1 to n do

    Read (M[i]) ;

    For i: = 2 to n do

    if M[i]-a = M[1] then k:=k+1;

    WriteLn ('1: k = ', k) ;

    k:=0;

    For i: = 2 to n-1 do

    if (M[i-1]M[i+1]) then k:=k+1;

    WriteLn ('2: k = ', k) ;

    Write ('3: ') ;

    For i: = 1 to n do

    if (M[i] mod 3 = 0) and (M[i] mod 5 0) then Write (M[i],' ')

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите! Нужно написать программы на Pascal + блок-схемы. С клавиатуры последовательно вводится n-целых чисел: 1) Сколько чисел отличаются ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы