Задать вопрос
7 ноября, 02:51

Составить программу

оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки отбрасываются и в зачет идет среднее арифметическое оставшихся оценок. составьте программу, которая определяет зачетную оценку спортсмена. оценки судей ввести в клавиатуры (целые числа от 1 до 6)

+5
Ответы (1)
  1. 7 ноября, 03:26
    0
    Var

    max, min, i:integer;

    b:real;

    a:array[1 ... 9]of integer;

    begin

    for i:=1 to 9 do

    begin

    while (a[i]6) do

    begin

    write (i,' оценка: ') ;

    readln (a[i]) ;

    end;

    if i=1 then

    begin

    max:=a[1];

    min:=a[1];

    end;

    if a[i]>max then max:=a[i];

    if a[i]
    b:=b+a[i];

    end;

    b: = (b-min-max) / 7;

    writeln ('Зачетная оценка: ', b) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу оценки на соревнованиях по фигурному катанию выставляются 9 судьями. потом одна самая высокая и самая низкие оценки ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы