Задать вопрос
10 мая, 08:01

Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр. Составить программу на паскале!

+2
Ответы (1)
  1. 10 мая, 11:18
    0
    Var

    N, B:longint;

    k:byte;

    Begin

    Write ('n = ') ; ReadLn (n) ;

    For n: = 1 to n do

    Begin

    k:=1;

    B:=n;

    While B>0 do

    Begin

    if B mod 100 then

    Begin

    if n mod (B mod 10) 0 then k:=0

    End

    else k:=0;

    B:=B div 10

    End;

    if k=1 then Write (n,' ')

    End;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти все натуральные числа, не превосходящие заданного n, которые делятся на каждую из своих цифр. Составить программу на паскале! ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы