Задать вопрос
29 ноября, 05:33

Написать программу, которая вычисляет количество четных чисел. Последовательность всех чисел задается с клавиатуры. Признаком окончания ввода последовательности чисел является значение любого отрицательного числа. Диапазон чисел {-10000; 10000}

+4
Ответы (1)
  1. 29 ноября, 08:28
    0
    Var x, y:integer;

    begin

    y:=0;

    repeat

    writeln ('Введите число') ;

    read (x) ;

    if x mod 2 = 0 then y:=y+1;

    until x<0;

    writeln ('Количество четных цифр = ', y) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, которая вычисляет количество четных чисел. Последовательность всех чисел задается с клавиатуры. Признаком окончания ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы