Задать вопрос
27 октября, 08:09

На паскале

Даны две строки. Определите, является ли первая строка подстрокой второй строки.

Входные данные

На вход подается 2 строки длины не более 10000, состоящие только из маленьких букв латинского алфавита.

Выходные данные

Необходимо вывести слово yes, если первая строка является подстрокой второй строки, или слово no в противном случае.

Примеры

входные данные

abac

ababacaba

выходные данные

yes

+1
Ответы (2)
  1. 27 октября, 09:44
    0
    Var S, S1:string;

    Begin

    ReadLn (S) ;

    ReadLn (S1) ;

    if Pos (S, S1) 0 then WriteLn ('yes')

    else WriteLn ('no')

    End.
  2. 27 октября, 10:54
    0
    Program ABC;

    var s, p: string;

    begin

    writeln ('Введите 1 строку:') ;

    readln (s) ;

    writeln ('Введите 2 строку:') ;

    readln (p) ;

    if (pos (s, p) 0) then

    writeln ('Yes')

    else

    writeln ('No') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «На паскале Даны две строки. Определите, является ли первая строка подстрокой второй строки. Входные данные На вход подается 2 строки длины ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы