Задать вопрос
9 апреля, 06:29

Составить программу вычисления средней температуры за месяц

+1
Ответы (2)
  1. 9 апреля, 07:29
    0
    Program z;

    uses crt;

    var

    s, x, i:real;

    begin

    clrsc;

    x:=0

    for i:=1 to 30 do begin

    writeln ('введите температуру') ;

    readln (x) ;

    sr:=sr+x;

    end;

    y:=sr/30;

    writeln ('ср темп равна', y) ;

    readln;

    end.
  2. 9 апреля, 08:48
    0
    const

    n = 30; / / n - количество дней в месяце

    var

    t: array [1 ... n] of real;

    i: integer;

    s: real;

    begin

    s: = 0;

    for i: = 1 to n do

    begin

    writeln ('Введите температуру ', i, ' дня') ;

    readln (t[i]) ;

    s: = s + t[i];

    end;

    writeln ('Средняя температура за месяц: ', s / n) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу вычисления средней температуры за месяц ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы