Задать вопрос
28 августа, 17:06

1) Написать программу, которая определяет номера строк двумерного массива A[1 ... 6,1 ... 4], в которых содержится хотя бы один нулевой элемент. 2) 5. Составить программу заполнения массива B[1 ... 10] таким образом: элементы с нечетными индексами равны числу 2, а элементы с четными индексами равны числу 5.

+3
Ответы (1)
  1. 28 августа, 18:46
    0
    1)

    var A: array [1 ... 6,1 ... 4] of integer;

    i, j: integer;

    begin

    randomize;

    for i : = 1 to 6 do begin

    for j : = 1 to 4 do begin

    A[i, j] : = random (20) - 10;

    end;

    end;

    for i : = 1 to 6 do begin

    for j : = 1 to 4 do begin

    if (A[i, j] = = 0) then begin

    writeln ("0 v stroke ", i) ;

    continue;

    end;

    end;

    end;

    end.

    2)

    var B: array [1 ... 10] of integer;

    i: integer;

    begin

    for i : = 1 to 10 do begin

    if (i mod 2 = = 0) then B[i] : = 5;

    else B[i] : = 2;

    end;

    for i : = 1 to 10 do begin

    writeln (B[i]) ;

    end;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «1) Написать программу, которая определяет номера строк двумерного массива A[1 ... 6,1 ... 4], в которых содержится хотя бы один нулевой ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы