Задать вопрос
1 ноября, 10:26

Определить, сколько раз в тексте встречается заданное слово. Написать программу, Паскаль

+4
Ответы (1)
  1. 1 ноября, 12:49
    0
    Var

    s, sl, sc: string;

    i, k: integer;

    begin

    write ('Введите текст ') ;

    readln (s) ;

    write ('Введите слово ') ;

    readln (sl) ;

    s:=' '+s+' ';

    sl:=' '+sl+' ';

    for i : = 1 to length (s) - length (sl) + 1 do

    begin

    sc : = copy (s, i, length (sl)) ;

    if sc = sl then inc (k) ;

    end;

    if k = 0 then writeln ('Не встречается')

    else writeln ('Встречается ', k, ' раз') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Определить, сколько раз в тексте встречается заданное слово. Написать программу, Паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы