Задать вопрос
22 августа, 14:53

Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).

+1
Ответы (1)
  1. 22 августа, 16:32
    0
    Var

    n, k:integer;

    begin

    Write ('Укажите число и номер инвертируемого бита: ') ;

    Read (n, k) ;

    Writeln ('Результат: ', n xor (1 shl k))

    end.

    Тестовое решение:

    Укажите число и номер инвертируемого бита: 573 4

    Результат: 557
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших). ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы