Задать вопрос
21 ноября, 04:57

Помогите в Pascal

№4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие единицы информации.

№5. Даны длины сторон треугольника A, B, C. Найти площадь треугольника S. Составьте программу решения поставленной задачи.

, где р - полупериметр

№6. Для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c).

+2
Ответы (1)
  1. 21 ноября, 08:15
    0
    4.

    var

    a:real;

    begin

    write ('Введите количество мегабайт=') ; read (a) ;

    writeln ('Количество килобайт=', a*1024) ;

    writeln ('Количество байт=', a*1024*1024) ;

    writeln ('Количество бит=', a*1024*1024*8) ;

    end.

    5.

    var

    a, b, c, p, S:real;

    begin

    write ('Введите сторону a=') ; read (a) ;

    write ('Введите сторону b=') ; read (b) ;

    write ('Введите сторону c=') ; read (c) ;

    P: = (a+b+c) / 2;

    S:=sqrt (p * (p-a) * (p-b) * (p-c)) ;

    write ('S=', s:5:2) ;

    end.

    6.

    var

    a:integer;

    begin

    write ('Введите количество суток=') ; read (a) ;

    writeln (24*a,' ','часов') ;

    writeln (60*24*a,' ','минут') ;

    writeln (60*60*24*a,' ','секунд') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите в Pascal №4. Дана величина A, выражающая объем информации в мегабайтах. Составьте программу перевода величины А в более мелкие ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы