Задать вопрос
27 сентября, 08:02

Висящие вешалки Мишу не устроили, и он решил создать арт-объект. Он повесил одну вешалку, а на ее перекладину - ещё две, получился арт-объект. Ему показалось мало, и он стал вешать на перекладину нижней вешалки ещё по две. В итоге у него получилось n этажей. Напишите программу, которая определит, сколько вешалок понадобилось ямище для создания арт-объекта. Входные данные: n<=100 Выходные данные: вывести одно число - количество необходимых вешалок. Пример: Вх.: 3, Вых.: 7

+1
Ответы (1)
  1. 27 сентября, 11:34
    0
    Можно просто вычислить 2^n-1 или (если не использовать функцию возведения в степень) сделать так:

    var n, i:integer; k:real;

    begin

    readln (n) ;

    k:=1;

    for i:=1 to n do k:=k*2;

    writeln (k-1) ;

    end.

    Пример:

    3

    7
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Висящие вешалки Мишу не устроили, и он решил создать арт-объект. Он повесил одну вешалку, а на ее перекладину - ещё две, получился ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы