Задать вопрос
4 августа, 20:11

Составить программу:

1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания

2. Задано четырехзначное число. Удалить из записи числа последнюю цифру. Определить, будет ли оставшееся число кратно 11

+3
Ответы (1)
  1. 4 августа, 23:08
    0
    1.

    uses crt;

    var x:integer;

    begin

    read (x) ;

    if inttostr (x) [1]>inttostr (x) [5] then

    writeln (inttostr (x) [1],' ', inttostr (x) [5])

    else

    writeln (inttostr (x) [5],' ', inttostr (x) [1]) ;

    end.

    2.

    uses crt;

    var x:integer;

    begin

    read (x) ;

    if (x div 10) mod 11=0 then

    writeln ('Yes')

    else

    writeln ('No') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу: 1. Задано пятизначное число. Выделить цифры, стоящие в разряде единиц и разряде тысяч. Вывести их в порядке убывания ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы