Задать вопрос
1 апреля, 09:55

Нужно написать программу на языке Паскаль условие такое:

вводится 15 чисел определить каких чисел кратных трём больше положительных или отрицательных

+4
Ответы (1)
  1. 1 апреля, 11:06
    0
    Var a, p, n, i:integer;

    begin

    p : = 0;

    n : = 0;

    for i : = 1 to 15 do

    begin

    read (a) ;

    if a mod 3 = 0 then

    if a > 0 then p : = p + 1

    else

    if a < 0 then n : = n + 1

    end;

    if p > n then writeln ('Положительных') else

    if p < n then writeln ('Отрицательных') else

    writeln ('Одинаково')

    end.

    {вариант "как-то посложнее"}

    var a, i, s:integer;

    begin

    s : = 0;

    for i : = 1 to 15 do

    begin

    read (a) ;

    s : = s + ord (a mod 3 = 0) * (ord (a > 0) - ord (a < 0))

    end;

    if s > 0 then writeln ('Положительных') else

    if s < 0 then writeln ('Отрицательных') else

    writeln ('Одинаково')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно написать программу на языке Паскаль условие такое: вводится 15 чисел определить каких чисел кратных трём больше положительных или ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы