Задать вопрос
7 декабря, 06:53

С клавиатуры вводится целое положительное число. Определить сколько в нем цифр и найти сумму цифр этого числа паскаль

+5
Ответы (1)
  1. 7 декабря, 07:34
    0
    Var n, sum, count: integer;

    begin

    read (n) ;

    sum : = 0;

    count : = 0;

    while n > 0 do

    begin

    sum : = sum + n mod 10;

    n : = n div 10;

    count : = count + 1;

    end;

    writeln (sum) ;

    writeln (count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «С клавиатуры вводится целое положительное число. Определить сколько в нем цифр и найти сумму цифр этого числа паскаль ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1) Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка. K вводится с клавиатуры. 2) С клавиатуры вводится целое положительное число. Определить, сколько в числе цифр.
Ответы (1)