Задать вопрос
21 января, 18:00

Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество минут, затем обязательно двузначное количество секунд. Количество минут и секунд при необходимости дополняются до двузначного числа нулями.

С начала суток прошло n секунд. Выведите, что покажут часы.

Входные данные

Вводится целое число n.

Выходные данные

Выведите ответ на задачу, соблюдая требуемый формат.

Примеры

входные данные

3602

выходные данные

1:00:02

входные данные

129700

выходные данные

12:01:40

+1
Ответы (1)
  1. Г
    21 января, 18:45
    0
    Var

    n, h, m, s: integer;

    begin

    read (n) ;

    n : = n mod (3600*24) ;

    h : = n div 3600;

    m : = n mod 3600 div 60;

    s : = n mod 60;

    write (h div 10, h mod 10, ':', m div 10, m mod 10, ':', s div 10, s mod 10) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Электронные часы показывают время в формате h:mm:ss, то есть сначала записывается количество часов, потом обязательно двузначное количество ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Войти
Задать вопрос