Задать вопрос
8 апреля, 03:06

В классе 20 учеников писали диктант по русскому. Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант (писать через массива)

+2
Ответы (1)
  1. 8 апреля, 04:27
    +1
    var

    a: array [1 ... 20] of 2 ... 5; / / Массив оценок учеников

    i: integer;

    n: array [2 ... 5] of 2 ... 5; / / Массив счетчиков оценок

    begin

    for i: = 2 to 5 do / / Обнуляем счетчики оценок

    n[i]: = 0;

    for i: = 1 to 20 do / / Вводим оценки учеников и считаем их

    begin

    writeln ('Введите оценку ', i, ' ученика') ;

    readln (a[i]) ;

    if a[i] = 2 then n[2]: = n[2] + 1;

    if a[i] = 3 then n[3]: = n[3] + 1;

    if a[i] = 4 then n[4]: = n[4] + 1;

    if a[i] = 5 then n[5]: = n[5] + 1;

    end;

    for i: = 2 to 5 do

    writeln ('Количество получивших ', i, ' за диктант равно: ', n[i]) ; {Выводим значения счетчиков}

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «В классе 20 учеников писали диктант по русскому. Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант (писать через массива) ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы