Задать вопрос
19 марта, 19:12

Напишите программу, которая в последовательности

N натуральных чисел определяет максимальное

число, кратное 4. Программа получает на вход N-ное количество чисел.

В последовательности всегда имеется число, кратное 4. Программа

должна вывести одно число - максимальное число, кратное 4.

+4
Ответы (1)
  1. 19 марта, 19:27
    0
    var

    i, n, k, max: integer;

    begin

    readln (n) ;

    max : = Integer. MinValue;

    for i : = 1 to n do

    begin

    readln (k) ;

    if (k mod 4 = 0) then

    max : = System. Math. Max (max, k) ;

    end;

    writeln (max) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая в последовательности N натуральных чисел определяет максимальное число, кратное 4. Программа получает на вход ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы