Задать вопрос
2 июля, 12:54

Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести количество нулей среди всех цифр числа N.

Примеры

входные данные

100

выходные данные

2

+3
Ответы (1)
  1. 2 июля, 16:15
    0
    Function ABC (A:integer) : integer;

    Begin

    result:=0;

    While A>0 do

    Begin

    if A mod 10 = 0 then result:=result+1;

    A:=A div 10;

    End;

    End;

    Var A:integer;

    Begin

    Read (A) ;

    WriteLn (ABC (A)) ;

    End.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы