Задать вопрос
30 мая, 10:19

Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение

+1
Ответы (1)
  1. 30 мая, 11:37
    0
    var

    m: array [1 ... 10] of integer;

    max, k, i: integer;

    begin

    for i : = 1 to 10 do

    read (m[i]) ;

    max : = m[1];

    k : = 1;

    for i : = 2 to 10 do

    if m[i] > max then

    begin

    k : = 1;

    max : = m[i]

    end

    else

    if m[i] = max then

    inc (k) ;

    write (k)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан массив из десяти целых чисел. Определите, сколько элементов этого массива имеют максимальное значение ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы