Задать вопрос
12 сентября, 18:56

Составьте программу из 16 случайных целых чисел от - 20 до 20, и опередяет, есть ли в этом массиве целые числа, равные 0. На экран выводятся исходный массив и индекс последнего найденого элемента

+3
Ответы (1)
  1. 12 сентября, 22:16
    0
    Begin

    var k:=-1;

    var a:array[1 ... 16] of integer;

    for var i:=1 to 16 do begin

    a[i]:=20-random (40) + 1;

    print (a[i]) ;

    if a[i]=0 then k:=i;

    end;

    if k-1 then writeln ('Индекс : ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составьте программу из 16 случайных целых чисел от - 20 до 20, и опередяет, есть ли в этом массиве целые числа, равные 0. На экран ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы