Задать вопрос
28 марта, 12:20

Написать программу, подсчитывающую сумму нечетных положительных элементов в одномерном массиве

+3
Ответы (1)
  1. 28 марта, 16:02
    0
    Const

    n = 10; var

    a : array [1 ... n] of integer;

    i, sum : integer;

    begin

    for i: = 1 to n do

    readln (a[i]) ;

    sum:=0;

    for i: = 1 to n do

    if (a[i] mod 2 = 1) and (a[i] > 0) then sum: = sum+a[i];

    writeln (sum) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Написать программу, подсчитывающую сумму нечетных положительных элементов в одномерном массиве ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы