Задать вопрос
24 ноября, 09:32

Дана неубывающая последовательность целых чисел вставить в нее целое число b таким образом, чтобы последовательность оставалось неубывающей. Учтите, что число может оказаться меньше первого или больше последнего элемента.

pascal

+2
Ответы (1)
  1. 24 ноября, 10:02
    0
    Const n=10;

    var a:array[1 ... n+1] of integer;

    i, j, b:integer;

    begin

    Randomize;

    writeln ('Исходный массив:') ;

    a[1]:=random (51) ;

    write (a[1],' ') ;

    for i:=2 to n do

    begin

    a[i]:=a[i-1]+random (51) ;

    write (a[i],' ') ;

    end;

    writeln;

    write ('b = ') ;

    readln (b) ;

    j:=1;

    while (j<=n) and (a[j]
    for i:=n downto j do a[i+1]:=a[i];

    a[j]:=b;

    for i:=1 to n+1 do write (a[i],' ') ;

    end.

    Пример:

    Исходный массив:

    3 21 47 74 104 134 146 177 184 222

    b = 120

    3 21 47 74 104 120 134 146 177 184 222
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дана неубывающая последовательность целых чисел вставить в нее целое число b таким образом, чтобы последовательность оставалось ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Pascal, задания на min max Дано целое число N и набор из N целых чисел. Найти количество элементов, расположенных после последнего максимального элемента.
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)