Задать вопрос
9 июня, 14:05

Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.

Входные данные

Первая строка входного файла input. txt содержит размер массива. Во второй строке записаны все элементы массива, разделённые пробелами.

Выходные данные

Программа должна вывести в файл output. txt все элементы отсортированного массива в одной строке, разделив их пробелами.

Примеры

входные данные

5

5 1 4 2 3

выходные данные

1 2 3 4 5

Free Pascal 2.6.2

+2
Ответы (1)
  1. 9 июня, 15:46
    0
    Program n1;

    type z = array of integer;

    var a: z;

    i, n, x, j, buf: integer;

    f: text;

    begin

    randomize;

    assign (f,'input. txt') ;

    reset (f) ;

    n:=0;

    readln (f, x) ;

    setlength (a, x) ;

    while not eof (f) do

    begin

    read (f, a[n]) ;

    n:=n+1;

    end;

    close (f) ;

    for i:=0 to n-2 do

    for j:=i+1 to n-1 do

    if a[i]>a[j] then begin

    buf:=a[i];

    a[i]:=a[j];

    a[j]:=buf;

    end;

    assign (f,'output. txt') ;

    rewrite (f) ;

    for i:=0 to x-1 do write (f, a[i],' ') ;

    close (f) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы