Задать вопрос
15 марта, 23:13

Помогите написать программу на паскале: даны 2 текстовых файла. определить в каком файле больше запятых

+5
Ответы (1)
  1. 16 марта, 02:19
    0
    Var f1:text;

    f2:text;

    s1, s2:string;

    k1, k2:integer;

    begin;

    assign (f1,'f1. txt') ;

    reset (f1) ;

    while not Eof (f1) do

    read (f1, s1) ;

    close (f1) ;

    assign (f2,'f2. txt') ;

    reset (f2) ;

    while not Eof (f2) do

    read (f2, s2) ;

    close (f2) ;

    while pos (',', s1) 0 do

    begin;

    delete (s1, pos (',', s1),1) ;

    inc (k1) ;

    end;

    while pos (',', s2) 0 do

    begin;

    delete (s2, pos (',', s2),1) ;

    inc (k2) ;

    end;

    if k1>k2 then writeln ('В первом') ;

    if k2>k1 then writeln ('Во втором') ;

    if k2=k1 then writeln ('Равно') ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на паскале: даны 2 текстовых файла. определить в каком файле больше запятых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы