Задать вопрос
11 февраля, 17:33

Задача "Справедливое распределение"

У Андрея было А грамм крупы, у Бориса - В

грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну

на троих. Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет

Андрею с Борисом.

Требуется написать программу, которая

определяет, как Андрей и Борис должны

поделить конфеты по справедливости.

Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или

из файла input. txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в

файл output. txt. В единственной

строке необходимо вывести два целых числа

- количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3

+5
Ответы (1)
  1. 11 февраля, 19:24
    0
    Var a, b, c:real;

    begin

    readln (a, b, c) ;

    writeln (round (c / (a/b)),' ', c-round (c / (a/b))) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача "Справедливое распределение" У Андрея было А грамм крупы, у Бориса - В грамм, а у Сергея вообще не было крупы. Ребята сварили кашу и ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы