Задать вопрос
26 декабря, 10:02

Задача №12

Найти номер элемента с заданным значением (все элементы разные).

программу по паскалю

+4
Ответы (1)
  1. 26 декабря, 11:24
    0
    Var a: array of integer;

    n, value, minind: integer;

    begin

    write ('Введите n: ') ;

    readln (n) ;

    a : = new integer[n];

    write ('Введите числа: ') ;

    for var i:=0 to a. Length-1 do

    read (a[i]) ;

    write ('Введите заданное значение: ') ;

    read (value) ;

    write ('Номер элемента с заданным значением: ') ;

    a[0]:=value;

    minind : = 1;

    for var i:=0 to a. Length-1 do

    if a[i]=value then

    begin

    minind : = i+1;

    end;

    writeln (minind) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Задача №12 Найти номер элемента с заданным значением (все элементы разные). программу по паскалю ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Все задачи делаются в Паскале! 1) Увеличить все элементы массива A на 1. 2) Умножить все элементы массива A на 2. 3) Возвести в квадрат все элементы массива A.
Ответы (1)
Укажите виды циклов А) с заданным условием продолжения работы Б) с полным ветвлением В) с заданным числом повторений Г) с заданным условием окончания работы Д) разветвляющийся
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Надо составить программу по паскалю) составить программу проверяющую утверждения, что сумма цифр введенного вами числа делится на 5.
Ответы (1)