Задать вопрос
15 августа, 01:28

Дан масcив из N целых чисел. Написать программу, определяющую, сколько в массиве чисел, равных максимальному элементу массива.

+3
Ответы (1)
  1. 15 августа, 03:53
    0
    Uses crt;

    const M = 100;

    var a: array [1 ... M] of integer;

    i, max, k, n: integer;

    begin clrscr;

    repeat

    writeln ('Введите количество элементов массива') ;

    readln (n) ;

    until (n 0) and (n>0) ;

    for i : = 1 to n do

    begin

    writeln ('Введите [', i, '] элемент массива') ;

    readln (a[i]) ;

    end;

    for i : = 1 to n do

    write (' ', a[i]) ;

    writeln;

    max : = a[1];

    for i : = 2 to n do

    if a[i] > max then max : = a[i];

    writeln (' max = ', max) ;

    for i : = 1 to n do

    if a[i] = max then k : = k + 1;

    writeln (' k = ', k) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дан масcив из N целых чисел. Написать программу, определяющую, сколько в массиве чисел, равных максимальному элементу массива. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы