Задать вопрос
26 ноября, 16:57

Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11

+3
Ответы (1)
  1. 26 ноября, 20:21
    0
    var

    s, k, err: integer;

    str: string;

    begin

    writeln ('Введённая пустая строка (без каких-либо символов) считается концом последовательности и, собственно, завершает выполнение программы, как бы говоря ей: "Эй, подруга! Выведи-ка количество чисел, не делящихся ни на два, ни на семь, ни на одиннадцать!"') ;

    while (true) do

    begin

    readln (str) ;

    val (str, k, err) ;

    if (err > 0) then break;

    if ((k mod 2 = 0) and (k mod 7 = 0) and (k mod 11 = 0)) then

    inc (s) ;

    end;

    writeln (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11 ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы