Задать вопрос
14 февраля, 00:13

Дано четырехзначное число. Написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой цифр заданного числа.

+2
Ответы (1)
  1. 14 февраля, 01:40
    0
    program a1;

    var

    a, b, c, r:byte; l, k:word;

    begin

    read (l) ;

    a:=l mod 10;

    b:=l div 10 mod 10;

    c: = l div 100 mod 10;

    r: = l div 1000 mod 10;

    k:=c*1000+r*100+a*10+b;

    write (k) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Дано четырехзначное число. Написать программу, которая находит число, образованное при перестановке первой и второй, третьей и четвертой ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы