Задать вопрос
28 февраля, 04:50

Найти

НОД (M, N, K) - наибольший

общий делитель трех чисел: M,

N и K. Числа M, N

и K хранятся в первой строке входного

файла Evclid. in, а НОД этих чисел

сохранить в выходном файле Evclid. out.

+5
Ответы (1)
  1. 28 февраля, 06:20
    0
    Program nod1;

    const InFile = 'Evclid. in';

    OutFile = 'Evclid. out';

    var m, n, k, nod, i, max: integer;

    begin

    assign (input, infile) ;

    reset (InPut) ;

    Read (InPut, m) ; Read (InPut, n) ; Read (InPut, K) ;

    Close (inPut) ;

    nod: = 1;

    if m > = n then

    max: = m

    else max: = n;

    if k > max then

    max: = k;

    for i: = 1 to max do

    if (m mod i = 0) and (n mod i = 0) and (k mod i = 0) and (i > nod) then

    nod: = i;

    assign (OutPut, OutFile) ;

    ReWrite (OutPut) ;

    Write (OutPut, nod) ;

    Close (output) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Найти НОД (M, N, K) - наибольший общий делитель трех чисел: M, N и K. Числа M, N и K хранятся в первой строке входного файла Evclid. in, а ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы