Задать вопрос
31 декабря, 10:28

Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10; 20]. Вычислить сумму положительных элементов последовательности, порядковые номера которых нечетны.

+2
Ответы (1)
  1. 31 декабря, 11:47
    0
    Var a : array[1 ... 50] of integer;

    sum, i : integer;

    begin

    randomize;

    for i : = 1 to 50 do begin

    a[i] : = random (31) - 10;

    if (a[i] > 0) and (i mod 2 0) then

    sum : = sum + a[i];

    end;

    write (sum)

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы