Задать вопрос
2 февраля, 12:14

Помогите написать программу на Паскале

Дан массив. вставить число К перед и после элементов, которые заканчиваются на ту же цифру, что и К

+1
Ответы (1)
  1. 2 февраля, 13:00
    0
    Const n=10;

    type mas=array[1 ... 3*n] of integer;

    procedure ins (var a:mas; k, nom:integer) ;

    var i:integer;

    begin

    for i:=3*n downto nom+3 do a[i]:=a[i-2];

    a[nom+1]:=a[nom]; a[nom]:=k; a[nom+2]:=k;

    end;

    var b : mas; k, i, j : integer;

    begin

    Randomize;

    for i:=1 to n do begin

    b[i]:=random (51) ;

    write (b[i]:4) ;

    end;

    writeln;

    write ('K=') ; readln (k) ;

    j:=1;

    for i:=1 to n do

    if (b[j] mod 10 = k mod 10) then

    begin ins (b, k, j) ; j:=j+3 end

    else j:=j+1;

    for i:=1 to 3*n do write (b[i]:4) ;

    writeln;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите написать программу на Паскале Дан массив. вставить число К перед и после элементов, которые заканчиваются на ту же цифру, что и К ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы