Задать вопрос
24 января, 00:37

Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC

Program eX_1;

var s: String;

n, i, b, j: longint;

c: char;

begin

writeln ('Введи текст из сообщения выше:') ;

readln (s) ;

for i:=length (s) downto 1 do

if s[i] in ['a' ... 'z'] then s[i]:=Upcase (s[i])

else if s[i] in ['A' ... 'Z'] then s[i]:=chr (ord (s[i]) + 32)

else if s[i] in ['0' ... '9'] then delete (s, i, 1) ;

write (s) ;

end.

+3
Ответы (1)
  1. 24 января, 04:06
    0
    Program eX_1;

    var s: String; n, i, b, j: longint; c: char;

    begin

    writeln ('Введи текст из сообщения выше:') ;

    readln (s) ; for i:=length (s) downto 1 do

    if s[i] in ['b' ... 'z'] then s[i]:=chr (ord (s[i]) - 1)

    else if s[i]='a'then s[i]:='z';

    write (s) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Нужно написать программу, что бы буквы заменялись на на "заглавные", а не те, что стоят перед ними в английском алфавите. PascalABC Program ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы