Задать вопрос
15 декабря, 16:53

Помогите по информатике!

Дана последовательность целых чисел, 0 - конец последовательности. Определите, сколько раз в последовательности меняется знак.

+1
Ответы (1)
  1. 15 декабря, 17:03
    0
    Var n, i, n1: integer;

    begin

    read (n) ;

    i : = 0;

    n1 : = 0;

    while n 0 do

    begin

    if n1 * n < 0 then

    i : = i + 1;

    n1 : = n;

    read (n) ;

    end;

    writeln (i) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Помогите по информатике! Дана последовательность целых чисел, 0 - конец последовательности. Определите, сколько раз в последовательности ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы