Задать вопрос
21 сентября, 13:32

Составить программу к решению задачи : "дано число n. Найти сумму и количество его цифр.

+4
Ответы (1)
  1. 21 сентября, 17:04
    0
    Var a, b, k, c, d:integer;

    begin

    read (a) ; k:=0; c:=10;

    while k0 do begin

    b:=b + a mod c; k:=a div c; inc (d) ;

    end;

    write (b, d) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу к решению задачи : "дано число n. Найти сумму и количество его цифр. ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы