Задать вопрос
12 марта, 02:47

Составить программу, выводящую количество корней квадратного уравнения

+2
Ответы (2)
  1. 12 марта, 04:36
    0
    Var

    a, b, c:integer;

    q:real;

    Begin

    Writeln ('a*x^2+b*x+c') ;

    Write ('Введите A: ') ; readln (a) ;

    Write ('Введите B: ') ; readln (b) ;

    Write ('Введите C: ') ; readln (c) ;

    q:=b*b-4*a*c;

    if q>0 then writeln ('2 корня') ;

    if q=0 then writeln ('1 корень') ;

    if q<0 then writeln ('0 корней') ;

    End.
  2. 12 марта, 05:27
    0
    Var a, b, c:integer; q:real; beginwriteln ('a*x^2+b*x+c') ; writeln ('vvedite a') ; readln (a) ; writeln ('vvedite b') ; readln (b) ; writeln ('vvedite C') ; readln (c) ; q:=b*b-4*a*c; If q>0 then writeln (2) ; If q=0 then writeln (1) ; If q<0 then writeln (0) ; end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, выводящую количество корней квадратного уравнения ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы