Задать вопрос
4 ноября, 23:08

для заданного одномерного массива с компонентами вещественного типа написать программу решения задачи:

вычислить разность между наибольшим и наименьшим элементом.

+3
Ответы (2)
  1. 5 ноября, 00:43
    0
    program fnued;

    uses crt;

    var a:=array [1 ... 1000] of integer;

    i, n, max, min, r:real;

    begin

    clrscr;

    readln (n) ;

    for i:=1 to n do

    readln (a[i]) ;

    min:=a[1];

    max:=a[1];

    for i:=1 to n do

    if a[i]>max then max:=a[i];

    for i:=1 to n do

    if a[i]
    r:=max-min;

    writeln (r) ;

    readln;

    end.
  2. 5 ноября, 01:56
    0
    program massiv;

    var

    a:array[1 ... 10] of integer;

    i, b, c : integer;

    begin

    writeln ('posledovatelno vedity elementi massiva (10 chisel) ') ;

    for i:=1 to 10 do

    readln (a[i]) ;

    b:=a[1];

    for i:=1 to 10 do

    begin

    if a[i]>b then

    b:=a[i];

    end;

    c:=a[1];

    for i:=1 to 10 do

    begin

    if a[i]
    c:=a[i];

    end;

    writeln ('raznost mesdu naibolshim i naimenshim elementom massiva = ', b-c) ;

    readln;

    end.

    p. s если нужны пояснения то в личку
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «для заданного одномерного массива с компонентами вещественного типа написать программу решения задачи: вычислить разность между наибольшим ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы