Задать вопрос
20 ноября, 00:31

Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные?

+3
Ответы (2)
  1. 20 ноября, 02:43
    0
    Var

    x, ed, des, sot:integer;

    Begin

    Readln (x) ;

    ed:=x mod 10;

    des:=x div 10 mod 10;

    sot:=x div 100 mod 10;

    x:=0;

    if sot mod 10=1 then x:=x+0 else x:=x+1;

    if des mod 10=1 then x:=x+0 else x:=x+1;

    if ed mod 10=1 then x:=x+0 else x:=x+1;

    if x>0 then writeln ('Есть') else writeln ('Нет') ;

    end.
  2. 20 ноября, 04:19
    0
    Var

    n, d1, d10, d100:integer;

    begin

    Write ('Введите натуральное трехзначное число: ') ; Read (n) ;

    d1:=n mod 10; d100:=n div 100;

    d10: = (n div 10) mod 10;

    if (d1 mod 2 = 0) or (d10 mod 2=0) or (d100 mod 2=0)

    then Writeln ('Есть четная цифра')

    else Writeln ('Нет четных цифр')

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу, позволяющую определить, есть ли среди цифр задорного целого трехзначного числа Х четные? ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы