Задать вопрос
10 июня, 19:23

Составить программу для решения задачи:

Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых больше среднего роста по классу.

+3
Ответы (1)
  1. 10 июня, 19:59
    0
    Const n = 25;

    var

    rost : array [1 ... 25] of byte;

    count, i : byte;

    sum: integer;

    begin

    randomize;

    for i:=1 to 25 do

    begin

    rost[i]:=random (40) + 150;

    inc (sum, rost[i]) ;

    end;

    for i:=1 to 25 do

    if rost[i]> (sum/n) then inc (count) ;

    write (count) ;

    end.
Знаете ответ на вопрос?
Не уверены в ответе?
Правильный ответ на вопрос 👍 «Составить программу для решения задачи: Рост 25 учеников класса представлен в виде массива. Определить количество учеников, рост которых ...» по предмету 📗 Информатика. Развернутая система поиска нашего сайта обязательно приведёт вас к нужной информации. Как вариант - оцените ответы на похожие вопросы. Но если вдруг и это не помогло - задавайте свой вопрос знающим оппонентам, которые быстро дадут на него ответ!
Искать готовые ответы